ZeroJudge C007: TeX Quotes

同題:UVa 00272 – TeX Quotes

TeX 是一種由 Donald Knuth 所發展出的一套文書排版軟體。這套軟體可以將原始文件檔加上一些像字型等型態後,轉成一份很漂亮的文件。而一份漂亮的文件是需要用 和 ” 來把別人說的話給「引」出來,而不是用大部份鍵盤上有的 ” 。雖然鍵盤裡通常不會有這種有方向的雙引號鍵,不過上面有左單引號`(有人叫 Backquote),和右單引號 ‘ (有人叫 Apostrophe 或 Quote)。你可以在你的鍵盤上找一下,不過要小心不要將 ` 與 \ (Backslash 鍵) 搞混了。而在 TeX 裡,使用者可以輸入兩個左單引號 來構成一個左雙引號 “ ,或者是兩個右單引號 ” 來構造一個右單引號 ” ,不過呢,通常大家打字時都很習慣用普通的雙引號 ” 來引述別人的話。

If the content of the original document file is:

“To be or not to be,” quoth the bard, “that is the question.”

Then the document produced by TeX would not be what we want:

To be or not to be,” quoth the bard, that is the question.”

In order to get the desired document, we need to transform the original document into this format:

To be or not to be,” quoth the bard, that is the question.”

你現在必須要寫一個程式,將普通的雙引號(”),轉成有方向性的雙引號,而其它文字則不變。而在把普通的雙引號換掉的時候,要特別注意,當要開始引述一句話時要用 ,而結束引述時要用 ” 。不用擔心會有多層巢狀引號的情形,也就是第一個引號一定是用 來代替,再來用 ”,然後用 “ ,接著用 ” ,依此類推。

Sample Inputs/Outputs

Sample Input(s)Sample Output(s)
EOF inputs: each data entry contains a string with space characters.
The output text must be identical to the input, except for the following:
每一組雙引號的第一個 ” 必須用兩個 ` 字元(就是 “ )來代替
每一組雙引號的第二個 ” 必須用兩個 ‘ 字元( 就是 ”)來代替。
Output the updated string.
“To be or not to be,” quoth the Bard, “that
is the question”.
The programming contestant replied: “I must disagree.
To C' or not toC’, that is The Question!”
“To be or not to be,” quoth the Bard, that
is the question”.
The programming contestant replied: “I must disagree. To `C’ or not to `C’, that is The Question!”
ZeroJudge C007 範例測資

Thought Process

Use getline to read each string and iterate through each character using a for loop. If the current character is ", you can declare a boolean variable initialized to true. If the boolean value is true, output “ and set the boolean value to false. If the boolean value is false, output ” and set the boolean value to true.

The boolean value needs to be declared outside the EOF.

Sample Code-ZeroJudge C007: TeX Quotes

#include <iostream>
using namespace std;

int main() {
    cin.sync_with_stdio(0);
    cin.tie(0);
    string str;
    bool start = true;
    while (getline(cin, str))
    {
        for (int i = 0; i<str.length(); i++)
        {
            if (str[i] == '"')
            {
                if (start)
                {
                    cout << "``";
                    start = false;
                }
                else
                {
                    cout << "''";
                    start = true;
                }
            }
            else cout << str[i];
        }
        cout << "\n";
    }
}

//ZeroJudge C007
//Dr. SeanXD

Comments